home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / media-libs / lcms-1.13-r1 / lcms-1.13-r1.ebuild < prev    next >
Text File  |  2005-10-18  |  1KB  |  62 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/media-libs/lcms/lcms-1.13-r1.ebuild,v 1.9 2005/09/19 06:49:07 hardave Exp $
  4.  
  5. inherit libtool gnuconfig
  6.  
  7. DESCRIPTION="A lightweight, speed optimized color management engine"
  8. HOMEPAGE="http://www.littlecms.com/"
  9. SRC_URI="http://www.littlecms.com/${P}.tar.gz"
  10.  
  11. LICENSE="LGPL-2.1"
  12. SLOT="0"
  13. KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ~ppc-macos ppc64 sparc x86"
  14. IUSE="tiff jpeg zlib python"
  15.  
  16. DEPEND="tiff? ( media-libs/tiff )
  17.     jpeg? ( media-libs/jpeg )
  18.     zlib? ( sys-libs/zlib )
  19.     python? ( >=dev-lang/python-1.5.2 )"
  20. RDEPEND="jpeg? ( media-libs/jpeg )
  21.     python? ( >=dev-lang/python-1.5.2 )"
  22.  
  23. src_unpack() {
  24.     unpack ${A}
  25.  
  26.     # an updated config.sub for the uclibc env
  27.     gnuconfig_update || die
  28.     elibtoolize  || die "elibtoolize failed"
  29.  
  30.     # fix build on amd64
  31.     cd ${S}
  32.     einfo "Running autoreconf..."
  33.     use ppc-macos || {
  34.         libtoolize --copy --force
  35.         aclocal || die "aclocal failed"
  36.         autoreconf || die "autoreconf failed"
  37.     }
  38. }
  39.  
  40. src_compile() {
  41.     econf \
  42.         --disable-dependency-tracking \
  43.         --includedir="/usr/include/${PN}" \
  44.         `use_with jpeg` \
  45.         `use_with tiff` \
  46.         `use_with zlib` \
  47.         `use_with python` || die
  48.     emake || die "emake failed"
  49. }
  50.  
  51. src_install() {
  52.     make \
  53.         DESTDIR=${D} \
  54.         BINDIR=${D}/usr/bin \
  55.         install || die "make install failed"
  56.  
  57.     insinto /usr/share/lcms/profiles
  58.     doins testbed/*.icm
  59.  
  60.     dodoc AUTHORS README* INSTALL NEWS doc/*
  61. }
  62.